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1 Introduction

RouteFinder 6.05

Welcome to RouteFinder, a network analysis system for MapInfo Professional.

RouteFinder offers a lot of functionality for routing:

· Point-2-point routing
· Traveling salesman optimization
· Distance matrices
· Nearest N calculations
· Route pairs
· Isochrones - 4 types
· Traffic volumes
· Service areas
· Clustering Algorithms
· Topological checks of the network
· etc.

This version is built on top of the RW Net 4 library and as such you cannot use networks
from RouteFinder 4 or older.

You can get up and running quickly by reading the Quick Start Guide

Known issues 
RouteFinder is incompatible with "Advanced Packing" tool, because it closes the map
window and RouteFinder then closes the network too.

1.1 System Requirements

RouteFinder for MapInfo:
MapInfo 10.0 - 15.0 (32-bit).
MapInfo 15.2.2 or greater (64-bit).

Hard disk requirement
80 MB with sample data.

Operating System
The application has been tested on Windows 7, 8, 8.1 and 10 (64-bit).

Access rights
The user needs to have admin rights to install the software.

Processor speed
Depending on the kind of tasks, you are performing with RouteFinder; a fast processor may
be a good idea.
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Especially large Batch Route  jobs requires some processing time, but also some of the
topology checking functions do take some time.

RAM
Depending on the size of the street networks you are going to work with, you may need
additional RAM.
As a rule of thumb each record in the street database requires a 50-150 bytes.

An example: A street network with 1,000,000 links will need a minimum of 50 MB RAM to
store the network.
When adding weight / width / height / road names / external ID etc. it may increase to 150
MB.

Using the 32 bit version will reduce the ability to work with large street networks.
There is no strict upper limit, since it depends upon several factors, but even on those
platforms up to 5 millions links should generally be possible.

Doing Voronoi based calculations may easily require 2-3 times more RAM than mentioned
above. This includes Voronoi Drive Time / Distance  and Service Area .

1.2 32 / 64-bit version

RouteFinder 6 is available in two versions, for 32 and 64-bit MapInfo.

They provide the same functionality and use the same data files for the routing.
They can both be installed and also share the same serial number / license file.

But you should only be running one of them at a time, since they share the user folder .

The 32-bit version can not use extended TAB files, since they can not be opened in that
version of MapInfo Professional.

The documentation shows screen dumps from the 64-bit version only, but the menu
structure is the same:

32 bit user interface

68
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This is made of the traditional menus and buttons.

64 bit user interface

This uses the new style Ribbon interface with button and drop down menus.

1.3 Installation Notes

Installation steps

You should install MapInfo Professional before you install RouteFinder.

If a previous version of RouteFinder has been installed, you can leave it in place. Just make
sure you install into different directories.

Now install RouteFinder by running the setup application. You must install RouteFinder and
not copy it from another machine. You should have administration privileges to perform the
installation.

After you have installed RouteFinder, open MapInfo and you will see RouteFinder  6.05
listed on the Home Tab > Tools > Registered pane (64-bit) or the Tool Manager (32-bit).

License file
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The way RouteFinder is licensed has now changed. It is now licensed via a remote server
with a serial number so you must have internet access available on the PC you are
installing the software. It will generate a license file that is to be used by the current user
only. This means that if you use the PC as a part of a job share then both users will need to
activate the software. We allow a certain number of activations with each license – if
however, the software does not activate then please contact RouteWare or Higher Mapping
Solutions.

When RouteFinder is first started you will see the following dialog:

You have the option of requesting a 30 day trial of RouteFinder. If you would like to do this
then tick the "Request 30 day trial". Fill in your name, company and email address. The
system will automatically generate a license file that will work for 30 days and can be used
on networks with up to 50,000 links. Once RouteFinder has been activated as a trial it will
not be possible to ask for a trial on the same machine.

When you purchase a copy of RouteFinder you will receive a serial number. If you have got
the serial number, then just put this into the first box and press OK. During the license
period you will get a further message to remind you how many days of your trial you have
remaining.
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If you are running a trial and then purchase a full license, then you can click on the "New
Serial" option on the main RouteFinder ribbon or menu and you will see the following
dialog:

When you enter you serial number - it will be validated and, if correct, will give you full
access to RouteFinder.

The license file will automatically be stored in the current users local folder - see "Settings
Folder" 

If no valid license is found, RouteFinder starts in "Free mode" with much reduced
functionality:
It will only allow a maximum of 3000 links and it is only possible to do shortest and fastest
routes and a simple isochrone.

Installed files
RouteFinder6.mbx: Main Mapbasic application
rwnet4.dll: routing library
RFIcons.dll in 32-bit version
FILELib.dll in 64 bit version
RouteFinder6.chm: This document

Icons folder
Used to display the menu items and for any symbol used to indicate restriction on a map.

EFAL folder
This folder allows the production of tables within RouteFinder.
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In the 64 bit version these are all NativeX tables, however this means that the result tables
cannot be used in a 32 bit version of MapInfo.

Settings folder
routefinderoptions.ini: Program options file
routefinder6.lic: license file, don't modify this
programerrors.log: Error log file (optional)

The settings folder  can be opened from within RouteFinder.

Sample folder

The sample folder  can be opened from within RouteFinder. This folder currently
contains some Open Street Map data.

If you are a new user then we highly recommend you read the “Quick Start Guide ” in the
Help file. 

If you were using a previous version of RouteFinder then please read the “Updating from
RouteFinder 4 ” or “Updating from RouteFinder 5 ” as appropriate.

1.4 Quick Start Guide

This guide is intended to get you up and running quickly with RouteFinder. It will allow you
to create a network, adjust road speeds and then you can use the functionality that you
need. When you are more familiar with the software you may want to create a new network
using some advanced features, such as one way streets and turn restrictions, in your
calculations.

You will need a topologically correct road network. There are such commercial datasets
from TomTom, HERE and Ordnance Survey. You can also use Open Street Map and the
UK Ordnance Survey free road dataset such as Meridian 2 and Open Roads. The minimum
requirement is a numeric column that has a value between 0 and 31. This will be your road
class column.

Open the network in MapInfo. Then start RouteFinder. You should be able to start
RouteFinder by going to HOME > Tools > Registered / Tool Manager.

When you scroll down the tool list You should see RouteFinder 6.05 in the main box.

53
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If you click on the load tool Icon, then the tool will be added to the MapInfo Ribbon. 

To start you need to create a network - This function is in the first part of the RouteFinder
Ribbon

You will then have the following dialog:
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Select your network table from the list and press OK.
You will then get to pick the column with the 0-31 values. 

If you have used one of RouteWare standard translators then you might get values in the
Attribute, Z Level From and Z level To fields.
If you do get those drop down boxes for z-levels filled in then it is fine to continue.
These fields just indicate links that form a part of a bridge or underpass and gives more
accurate routing results. 

When you click OK the network files are created and the RouteFinder features are enabled.
You will see a message telling you options are set to by default.
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More details can be found in the Creating a Network  chapter.

The first step will be to input your roads speeds.
In order to do this you will need to know what number in the Attribute field relate to what
kind of road.
E.g Class 1 might be a Motorway, Class 2 might be a major road and so on.
To change road speeds you would go to the Options > Set Road Speeds.

The following dialog is displayed:

22



11Introduction

© 2023 Higher Mapping Solutions & RouteWare

First select if you want Mph or Km/h.

To change a road speed click on a class and then input the required speed into current
road speed box.
You can optionally also click the edit button to input a new name for the road class.

By doing this you can make the roads speeds name more understandable.
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Further details of this function can be found in the Road Speed Options chapter

Once you have done this you are ready to start using the functions in RouteFinder. You can
set the type of calculation you want to do by using Options > Route.

31
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This is one of the major changes in the interface from previous version of RouteFinder. We
now have the concept of a vehicle and that vehicle could have a number of properties such
as using one way streets or calculating costs. Each vehicle can have its own speed file
associated with it. So you can have a car that uses one set of speeds and a Heavy Goods
Vehicle, which has a different speed file. This combined with the calculation of costs and
the use of limits makes it very easy to calculate for vehicles with different uses. You can
learn about the details of this dialog by looking at the Route Options  chapter

In this dialog you can choose if you want shortest  or fastest  calculation type. 

Please refer to the rest of the help file for information on how to use the tools in
RouteFinder.

1.5 List of Network Files

This is a list of the files you will typically be working with.
You need to have write access to the folder with these files, but the roads table itself can be
read-only for most operations.

Basic set of files

Roads table *.tab
Configuration file routefinder.ini
Speed files *.spd
RW Net 4 files attribute.bin

coord.bin
coord3.bin
coord3i.bin
length.bin
link.bin
node.bin
spatialindex.bin
rwnet_config.ini

34
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Optional files

Unique external ID index1.bin
index2.bin

Avoid setup limit1.bin
Max Width limit2.bin
Max Height limit3.bin
Max Weight limit4.bin
Turn restrictions turn.bin

turn.txt
Restrictions restrictions.tab
Driving directions roadname01.bin

roadnumber01.bin

1.6 Support

RouteFinder is supplied in two versions, which are feature-wise the same, but they are sold
and licensed separately.
Please check with the About box, if you have one or the other, before asking for support:

RouteWare version:
You get free support via e-mail during your evaluation period and a further 30 days of
support from the date of purchase.

If you require support after this period, contact us at contact@routeware.dk for details of
our additional support contracts.

Precisely version:
Please contact your sales representative.

1.7 History

Version 6.05 - 8th Mar 2023 (build 18)
Bug fix related to using miles in a few isochrone functions.

Version 6.05 - 19th Feb 2023 (build 17)
Cluster 1 analysis  method added.
Minor bug fixes

Version 6.04 - 30th Oct 2022 (build 16)
Minor bug fix for routing with NoDriveThrough in combination with NearestOpen.

Version 6.04 - 26th Jan 2022 (build 15)
Fix for opening network in MapInfo version 2021.
Minor bug fixes

Version 6.03 - 10th June 2021 (build 14)

103
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Fix for TABx with UTF-16 and long char fields

Version 6.03 - 21st July 2020 (build 12)
Fix for licensing of >1 user

Version 6.03 - 25th May 2020 (build 11)
Bug fix to Update Point File
Bug fix to Table Joined By ID only calculating in km.
Bug fix to Route Pairs only calculating in km.
Bug fix to using tables with spaces in name.
Better support for duplicate links (See Creating a Network )
Table name in alphabetical order in drop down boxes

Version 6.02 - 25th Nov 2019 (build 9)
Fixed output to UTF-8 format in 64-bit version to prevent codepage issues.

Version 6.01 - 6th Nov 2019 (build 8)
Fix for UTF-16 encoded tables with decimal fields.

Version 6.01 - 30th October 2019 (build 7)
Ability to select which links are used for Isochrones added. See Isochrone options  for
more information.
Bug fix for generation of empty data sets.
Bug fix to batch service area function

- Name of service are now updated
- Isochrone cut-off value now works in both Km and Mi

Version 6.00 - 1st July 2019
Major new release!
You can see the main changes from version 5 here .

Version 5.16 (Build 59) - 10th February 2019
Final version 5.x

Version 5.00 - 25th June 2016
Major new release!
This is the first version available for the 64 bit version of RouteFinder for MapInfo
Professional.

1.8 Changes from RouteFinder 5

Licensing

RouteFinder now uses a serial number to activate. It is now licensed per user and you get 4
activations per license.
This means that if you have a single user user license then you can activate it on the same
PC for different logins but it is not a roaming license.
The PC or laptop name that it is installed on is recorded in our database.

28
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If you are on maintenance then we can check for updates and if within time maintenance
period, then you will be granted access to updates and a message will be displayed to the
user to inform them of an update. The PB version will also check for updates on our server.
You will see this message:

System support

Support for LARGEINT 
We can now use the LargeINT field type in tables.

EFAL for output
We now use the Extended File Access Library (EFAL) to produce the result tables used in
RouteFinder.
In the 64 bit versions RouteFinder will produce the results in NativeX format.
This allows for very large result tables to be produced.

Loop link check
When creating a network in RouteFinder the system will check for loop links in the Network.
If any are found then a message will be displayed and the network creation process will be
halted.
The user will need to remove or split the loop links before a network can be produced.

Subnet Check
When opening a network a  quick subnet check. If any subnet exist then a message is
displayed.
This message can be ignored until the next time the network is created or you can be
reminded the next time the network is loaded.
We recommend you remove subnets as they can cause errors in the routing calculations.

Better Handling of Read Only files
RouteFinder will now disable functionality automatically if file cannot be used because it is
read only. The files that will be checked are speed files, RouteFinder.ini and and the
network table.
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New Features

Graduated Isochrone
New isochrone type that does not have fixed boarders so the colours graduate. In this
version the colours are fixed.

Cluster Analysis
Cluster a point dataset around a user defined number of centres to minimise travel time or
distance.

Location to Facilities
Cluster a set points to user defined facilities. Facilities have a capacity but will minimise
travel time or distance.

Centre Point of Network
Define the centre point of the network based on distance.

New Route Options dialog
The dialog has been redesigned to group similar operation together. New options have
been added.

New No Through Road option
Routes can now be calculated to take into account no through roads. Routes can still start
or end on a link defined as No Through Road but it cannot be traversed as a part of longer
route.

Allow a Fixed Travel Time  on a link
Links can now be set to a fixed time to traverse the link. This could be because of road
works.

Time display
Display time as string eg 1h 25m 35s, as well as a decimal number. For batch functions
both formats are still generated.

Attribute Calculator
Road classes and other options can be set for one or more links.

Keep display of interactive results
Results of previous interactive measurement can be left on the screen and only cleared by
the user.

New currency symbol format
Currency is now displayed as three letter to represent the selected currency such as GBP,
EUR or USD.

Max Speed on Vehicle
You can now set a speed at which a vehicle cannot exceed no matter what speed is
defined on a link.

61
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Various small improvements to existing functions.
More batch Isochrones work in dynamic segmentation mode.
Maximum cut-off value on matrix calculations.
Cost field name has the currency appended if one has been defined in the program
options .
Improved reporting when using a time limited or link limited license.
Better handling when loading points in batch functions with deleted row or rows with no
object or points outside of the network.
Allow changing of avoid descriptions from the Route Options  dialog.
Avoiding creating networks with projections that could cause problems.
Better handling when creating tables greater than 2GB in the 32bit version.
Better handling of turn restriction when using external id's.

Preparing networks for RouteFinder 5, with RouteFinder 6

If you prepare a network in RouteFinder 6, but have to send it to a RouteFinder 5 user,
please follow these steps after preparation:

1) In RouteFinder.ini, set version = 5 in the [Info] section.
The ini file contains several other new elements, which will be ignored in version 5.

2) If you have imported (turn) restrictions with 64-bit RouteFinder, the restriction table will
be in NativeX format.
Change that to Native format, if you are going to use it with 32-bit RouteFinder.

3) In restrictions table, delete type=16.

1.9 Updating from RouteFinder 5

If you open a version 5 network in RouteFinder 6 you will see the following message:

No further changes will be needed to use the network, but it will not be able to be used in
version 5 of RouteFinder.

51

34



19Introduction

© 2023 Higher Mapping Solutions & RouteWare

If you try to open a version 4 network in RouteFinder 6 then you will see the following
message:

Please see the chapter on updating networks from version 4.

1.10 Updating from RouteFinder 4

RouteFinder 6 cannot use any of the binary files from a version 4 network. If you have
existing street networks from RouteFinder 4, follow these steps to update:

· Copy the main TAB file to a new folder.
· If you have a turn.txt file, copy it to the same folder.
· Bit 5-6-7-8 (mode bits) in the attribute field should be cleared, if set ( that is if you have

added 32, 64, 128, 256 to any attributes).

Now you are ready to create a network from the TAB file.

The rest of the files are not compatible with RouteFinder 6:

1) routefinder.ini
2) *.spd files
3) *.bin files
4) restrictions.tab (if generated by RouteFinder)

1.11 License Agreement

RouteFinder 6 for MapInfo Professional
© 2001-2022 by RouteWare and Higher Mapping Solutions
All rights reserved

SOFTWARE LICENSE
A single user license permits the use of RouteFinder on a single computer. Multiple user
licenses will be subject to the terms and conditions granted in such license.
You may not translate, reverse engineer, decompile, disassemble, modify or patch the
RouteFinder executable files or documentation in any way.
You may not use the RW Net 4 DLL outside of RouteFinder in any way.

LIMITED WARRANTY
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RouteWare warrants that all disks provided are free from defects in material and
workmanship, assuming normal use, for a period of 90 days from the date of purchase.

RouteWare warrants that the program will perform in substantial compliance with the
documentation supplied with the software product. If a significant defect in the product is
found, the Purchaser may return the product for a refund. In no event will such a refund
exceed the purchase price of the product.

EXCEPT AS PROVIDED ABOVE, ROUTEWARE DISCLAIMS ALL WARRANTIES, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT
TO THE PRODUCT. SHOULD THE PROGRAM PROVE DEFECTIVE, THE PURCHASER
ASSUMES THE RISK OF PAYING THE ENTIRE COST OF ALL NECESSARY
SERVICING, REPAIR, OR CORRECTION AND ANY INCIDENTAL OR CONSEQUENTIAL
DAMAGES. IN NO EVENT WILL ROUTEWARE BE LIABLE FOR ANY DAMAGES
WHATSOEVER (INCLUDING WITHOUT LIMITATION DAMAGES FOR LOSS OF
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION
AND THE LIKE) ARISING OUT OF THE USE OR THE INABILITY TO USE THIS
PRODUCT EVEN IF ROUTEWARE HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES.

Use of this product for any period of time constitutes your acceptance of this agreement
and subjects you to its contents.

1.12 SDK

RouteFinder is built on top of RW Net 4, which is available as a separate SDK (software
development kit).

Please see the RouteWare website for details about RW Net 4.

1.13 Acknowledgements

Thanks to Peter Møller for use of his RibbonLib for menu building in 64-bit MapInfo.

EFAL is Pitney Bowes library for writing TAB files and much more.

Thanks to OpenStreetMap for providing what is the basis of our sample data.
However, our version is heavily modified to illustrate various elements of RouteFinder.
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2 Basic Functions

This section explains how to create a network from a MapInfo Table and how to set the
options that affect how routes or isochrones are calculated.

You can also set various options for some program wide settings.

2.1 Creating a Network

Go to Create Network 

In order to create a network to use for routing with RouteFinder, these steps should have
been prepared first:

Input file
You need to have a TAB file in either native format or native extended format (64 bit only).
Tabular data must be stored in DAT or DBF file.

It should only contain lines and single-sectioned polylines.
Loop polylines should be split.
The table must be packed.

The coordinate system must be geographical or projected / cartesian.
For instance Web Mercator can not be used.

Road class attribute
This field will define the different classes of roads. The basic classes of road should be
between 0 and 31. To define a one way street add 512. Add 1024 to create a one-way
street that has been digitised in the wrong direction.

Each road class from 0 to 31 can be assigned a different speed through the Road
Speed  options after the network has been created and loaded.

An example: If the first link in the network is a class 1 road (e.g. a motorway), which can
only be travelled in the direction of digitizing, the attribute will be 1 + 512 = 513.

There are more settings you can add manually to a link and they are:

Add 256 if it is a no through road. A route can start or finish on the link but it cannot be used
as route through to another link on the network
Add 512 if it is a one-way street, which may be travelled in the digitised direction. 
Add 1024 if it is a one-way street, which may be travelled in the opposite to the digitised
direction. 
Add 2048 if a link is part of a roundabout. This is used in generating driving directions. 
Add 4096 if a link is a "non-driving" link. This can be used to mark ferries and car trains, so
their length is not included in driving directions. 
Add 8192 if it is not allowed to make U-turns at the from-end of the link.

31
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Add 16384 if it is not allowed to make U-turns at the to-end of the link.
Add 32768 if it is not allowed for a route to start on the link.

If you don't have any information about road classes, just add an integer field with all zero's.
This means the same speed is used all over the network and all links can be traveled in
both directions.

Actual creation of network

When the steps above has been taken care of, you are ready to create a network.
From the RouteFinder TAB select the "Create Network" from the first group of controls. The
following dialog is displayed:

Select the required table from the list displayed

If the table required is not currently open then use the open table button to select the
required table.

If your table has deleted rows you will be prompted to to pack the table before the rest of
the process can continue.

A default speed file will be created if one has not been previously generated.
You can use Options > Set Roads Speeds to adjust the required speeds for each class of
road.
You can also create other speed files  to represent walking speeds, buses or any other
transportation mode.

If a network for the selected table already exists, then you will be prompted to confirm
overwriting of the network files.

31
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When the user clicks on the OK button the next dialog is displayed

After pressing OK you may also be asked if you want to keep your existing speed file.
This is useful when you are creating a network after a small change but the road classes
have remained the same.
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Attribute Column
Select the attribute column to use by selecting it from the drop down list. This field will have
previously been set up as defined above.

Z-Levels
If the network has Z-Levels (Grade separations defining bridges and under passes), then
you can use the next two drop down boxes to select the column for these values.
Z-levels is a number from -9 to +9, with the majority of the values being 0.

Limits
It is possible to define height, width and weight restrictions and these are store in a smallint
column (range 0-255) in the table and affect the link associated with that row.

Height restrictions are defined in tenths of a meter in 0.1 steps (i.e 73 = 7.3 meters)
Width restrictions are defined in tenths of a meter in 0.1 steps (i.e 52 = 5.2 meters)
Weight restriction are define in half a tonne steps (i.e 19 = 9.5 tonnes)

These values are stored in their own columns and more than one restriction can be defined
on each link.

Route Description Column
The route descriptions are set from the column containing the relevant data and is selected
from the drop down list.
When a route or traveling salesman has been generated, a window will appear with the
directions and it will also be possible to click on each part of the route description and see it
highlighted on the map.
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Avoid Column
This column will hold details of situation when this link should be avoided. It might be that
the link is not safe to walk on or you may want to avoid toll-roads. Up to 8 avoids can be
defined on a single link.

In order to define avoids you would add the following values to Avoid column in your table

1 - Avoid setting 1
2 - Avoid setting 2
4 - Avoid setting 3
8 - Avoid setting 4
16 - Avoid setting 5
32 - Avoid setting 6
64 - Avoid setting 7
128 - Avoid setting 8

The avoid values are additive so if you wanted a specific link to be avoided in option 1, 2, 5
and 6 then the value in the avoid column in your table would be:

1 + 2 + 16 + 32 = 51

You can manage these settings via the Set Avoids  option in the restrictions group.

Unique Network ID Column
This column would contain a unique reference for a link in the database. It would be used
when you want to import turn restrictions that are based on a Link ID rather than a row id.
When picking a field, it is checked if it is actually unique.

Loop Links
If your network contains any loop links then you will see this message:
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An example of a loop link is shown below.

You will need to split these links before a network can be created.

It is also possible that you will see the following message:

If any subnets exist in the network being opened then a message is displayed.
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This message can be ignored until the next time the network is created or you can be
reminded the next time the network is loaded.
We recommend you remove subnets as they can cause errors in the routing calculations.
You can use the subnet check  in the analyze menu.

On a successful network loading you will see a summary screen detailing the current
settings.

Working with duplicate links

From version 6.03 there is now limited support for duplicate links. For example:

Here the duplicate links have been separated to show the differences. 

In this example there are 2 geometrically identical links, with opposite one-way restrictions
(512 and 1024).

Each link can have its own class attribute associated with the link. This means that each
link can have its own speed.
It might replicate a situation where a road may be free flowing in one direction but really
slow in the other perhaps because of rush hour or regular congestion.
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RouteFinder will take that into account when doing these calculations:
· Route
· Route Pairs
· Joined Table
· Select Locations without optimization
· Traffic Volume
· Update Point File

It is supported here, if "avoid through roads" is true for the active vehicle:
· Distance Matrix
· All optimizations (including TSP)
· Select Locations with optimization

It is not supported in:
· Nearest N Centres
· Isochrones
· Service area
· Most kind of network analysis

2.2 Network Topology

Possible Network Errors

Below is  shown some examples  on networks , which are  NOT correct, but a ll look
correct unless  you check out the  deta ils :

Missing snap at an intersection
This  means  the  network doesn't connect and the  movement to from the
disconnected section, isn't poss ible .
In the  example  below, the  gap is  jus t 1 meter and can't be  seen a t normal zoom
levels .

These  can be  detected by us ing the  Close  Node Check.

Split at overpass / underpass
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This  means  a  lot of imposs ible  turn movements  are  suddenly made poss ible .

However your data  may have z-levels  in which case  these  are  used to overcome
this  is sue .

The z-levels  work in the  direction of the  road and the  e levation is  defined by a
series  of numbers  to indica te  re la tive  height.
Numbers  between -9 and 9 are  used for this  purpose .

Doesn't split/break at intersections
This  means  turns  are  not poss ible  a t intersections , because  no proper node exis ts
a t the  point where  they touch.
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These  errors  can be  detected by us ing the  Node-Link check

Multi sectioned Polylines
Polylines  with more  than 1 section are  ignored. They will not form part of any route .

These errors are detected during the network creation process.
There will be a file called Network_Report.txt in the same folder as the network table.
We recommend you check this file after creating a network

2.3 Road Speed Options

Go to Options > Road Speeds 

If the speed file is read only you will see this message. You will not be able to change any
of the options in this dialog.
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If the file is not read only then you will see the following dialog:

This dialog is used for maintaining  all the speeds files used for this network. You would
then allocate a speed file to a vehicle in the Route Options Dialog - It does not change the
current speed settings unless it is the current speed file in use. The speeds for different
classes of road are defined in a *.spd file that will be in the same directory as the network
files. This is a simple text file that can be edited, but care will be required and we do NOT
recommend you do edit files outside of RouteFinder. If you do so it will be at your own
risk.

Select Speed File

You can have multiple speed files that hold different speed for the same network.
This means you can have a speed file for peak, off peak or even walking speeds.
To edit a different speed file, simply select it from the drop down list.
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The setting for the selected speed file is then displayed.

Save As

If you want to create a new speed file then saving a copy of an existing file is a good place
to start.
If you click on "Save As" the following dialog is displayed:

When you enter a new name a new speed file is created and added to the drop down list.

This next part explains how you maintain the classes and descriptions within a speed file.

Adding a road class

When the user clicks on the "Add" button they will be prompted to enter the type of class (a
number from 0 to 31) and a description for this class. This is shown below:

Editing a description

Selecting the relevant item from the list and then clicking on the edit button can change the
description displayed in the list box. The user is then prompted for the new description.
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Deleting a road class

Selecting the relevant item from the list and then clicking on the Delete button will remove
that class from the list box.

Changing the road speed

i) Selecting the relevant class from the list.
ii) Input the new speed in the "Current Road Speed".
iii) When you select another class the speed is updated

Distance Units

The distances returned by the routing operations and the speed units are set by selecting
either "Mph" or "Km/h".

It is important to understand the hierarchy of how the speeds are applied to road links.

The first level is through the road classes and the related speeds you have just entered.
These speeds are then superseded if a column with speeds per link are loaded through the
Route Options . If any road link in a column has a zero in it, then it is ignored.
These speeds are then superseded if a column with time per link are loaded through the
Route Options . If any road link in a column has a zero in it, then it is ignored.
Finally, if the user overrides the speed on a link by using the Change Road Speed  tool
then this speed will take precedence over the other settings.

2.4 Route Options

Go to Options > Route 

We have the concept of a vehicle and that vehicle have a number of properties such as
using one way streets or calculating costs. Each vehicle has it own speed file associated
with it. So you could have a car that uses one set of speeds and a Heavy Goods Vehicle
which has a different speed file. This combined with the calculation of costs and the use of
limits makes it very easy to calculate for vehicles with different uses.
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When the item is clicked the following dialog is displayed:

Calculation Group

Shortest or Fastest
You should select the calculation type required shortest or fastest. This will determine
whether upon calculating a route, the shortest or fastest path is generated. This also affects
the Drive Time Polygons and all other calculations. In "Fastest" Mode the polygons
represent actual drive time, whilst in "Shortest" mode the polygons will represent Drive
Distances. The menus are changed to show which mode you are currently working in. 

Use One Way
With this option checked one-way street restrictions are obeyed. When unchecked then the
network effectively becomes a walking network where you can go both ways on a one way
street or any direction around a roundabout.

Reverse
With this option checked then all the one-way street restrictions are reversed. This is
especially useful in combination with isochrones which are calculated from the center. If
your interest is an isochrone showing how to get to the center, use this option. Note: You
can not reverse turn restrictions the same way.

Use Restrictions
This will allow your network to use any turn restrictions that are available on the network.
The restriction will have been previously set up on the network either manually or via the
Import Turn File  option. It should be noted that turn restrictions are not used when
generating multi-centred isochrones (that is link and voronoi isochrones).

Always find an open link
If the user clicks and the nearest link is closed because of the Avoid settings or some other
reason then this option will find the next nearest link that is open and routing can take
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place. While this gives greater usability for the user they have to be aware it can lead to
misleading results and so they use this at their own risk.

Avoid no through roads
If this option is checked then if there are links that have been defined as no through roads
then this will be taken into account when performing route calculations. However there are
some functions where the no through attribute is ignored and these are Nearest N Centers,
All Isochrones including Service Area and Center of Network.

Calculating matrices gets a lot slower, so don't set this option, unless you actually have "no-
through-roads" and these are important to your calculations.

Speed Profile

Each vehicle can have its own speed profile or use a speed column in the table. You can
have multiple speed files that hold different speeds for the same network. This means you
can have a speed file for peak, off peak or even walking speeds.

To set a speed file for the current vehicle just click on the drop down box and select the
required one.

If your road dataset has a speed allocated to each link then you can overwrite the default
road class speed as defined by the attribute. By checking the Use a Speed Column option
you can pick a relevant numeric field. The first thing you will see is a warning to make sure
the speeds in any column you select will be the same units as the currently loaded speed
file:

Then you can select the column from you table:
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 Any records that have a zero will be ignored and the default road speed will be used.

If you have a column in your table that has links with Fixed Times then you first check Fixed
Time Column then you can select the column in the network table that has the times in
minutes.

Maximum Speed
If you put a value in this box then it will set the current vehicle to a speed which the vehicle
will not exceed no matter what the speed is on any particular link.

Limits

Use Vehicle Properties
In order to use this section you will have had to have imported any height, width and weight
restriction columns as a part of the network creation process. If you have done this then you
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will be able to enter limits for your vehicle that are then taken into account during any
calculation process. To enter the limits for the current vehicle, tick the "Use Vehicle
Properties" box and then any limits that can be used will be enabled.

Enter the required limits for the currently selected vehicle. The limits will be checked to
make sure they do not exceed a valid range when the vehicle is changed or the OK button
is pressed.

Avoid Group

This option is only enabled if you have imported a column from your table that contains the
avoid pattern as a part of the network creation process.
This will let you run the same network in different ways. For instance, you may decide you
want to avoid all motorways or trunk roads (if you were walking for instance) then you can
define those avoid values in a column in your table. 

That value is then used if you set a particular vehicle to avoid certain types of roads during
the calculation process. In order to define avoids you would add the following values to
Avoid column in your table:

1 - Avoid setting 1
2 - Avoid setting 2
4 - Avoid setting 3
8 - Avoid setting 4
16 - Avoid setting 5
32 - Avoid setting 6
64 - Avoid setting 7
128 - Avoid setting 8

The avoid values are additive so if you wanted a specific link to be avoided in option 1, 2, 5
and 6 then the value in the avoid column in your table would be:

1 + 2 + 16 + 32 = 51

This link would then be avoided if any of the 1, 2, 5, 6 check boxes were ticked.

You can set the names for each avoid option by using the Set Avoids  option in the
restrictions ribbon group.

Route Style
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The route style button will allow the user to select the line style used to display calculated
routes on the map.

From here the user can choose the style, colour and thickness of the line used to display
routes. This dialog may vary from version to version of MapInfo Professional.

Costs

If you want to estimate the financial cost for using a vehicle the values can be entered here.
To enter the limits for the current vehicle tick the "Calculate Costs" box and then three
boxes below that will be enabled.

When a route calculation is performed you will see the cost appear in the message window
or if it is a batch function, it will be an extra column in the result table.

Route Type Group 

Route Descriptions
The route descriptions are switched on or off for the calculation that produce a route. This
option is only enabled if you have imported road names as a part of the network creation
process.

Also Calculate Straight Line Distances
When this option is checked you will get a straight line measurement for the requested
function as well as the normal Time and distance calculations. An example of this is shown
below:
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This is used to control the dynamic segmentation options. These are as follows:

Exact (dynamic segmentation)
The route is calculated from the nearest part of a link from where the user clicked. The
resulting route will take into account the amount of time and distance to travel the partial
segment of the link.

Exact with Off road 
This is the same as the above option except it will also add a link from the point where the
user clicked to the nearest part of the network. To use this option you will need to put in an
off road speed. This is used to estimate the amount of time it takes to get from the start and
end points to the network. The resulting route will take into account the amount of time and
distance to travel the partial segment of the link. 
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Adding and Removing Vehicles

A default vehicle should always be set up by the program but you can add and remove your
own vehicles.

Add Vehicle
When you click this button you will be prompted to enter a name for new vehicle.

You can accept the default name or change it to something else. When you press OK this
vehicle is added to the list and the options reset ready for you to enter a new set of details. 

Delete Vehicle
When you click this button the currently selected vehicle is deleted from the list and the first
vehicle is then loaded up.

Rename Vehicle
When you click this button then you are prompted to enter the new name for the currently
selected vehicle.
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When you have made all the changes required and OK is clicked then the settings are
applied.

It is important to understand the hierarchy of how the speeds are applied to road links.

The first level is through the road classes and the related speeds you have just entered.
These speeds are then superseded if a column with speeds per link are loaded through the
Route Options . If any road link in a column has a zero in it then the road class is used.
Finally, if the user overrides the speed on a link by using the Change Road Speed  tool
then this speed will take precedence over the other settings.

2.5 Drive Time Options

Go to Options > Drive Time or Drive Distance 

The following dialog is displayed which allows you to add, delete or amend the number of
zones or the way they look.

The dialog shows a list of zone's added for generation of isochrones. The values reflect
either distance or time depending on the choice of shortest or fastest route. Default values
are 3 zones with values of 5, 10 and 15.
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Adding a Zone
When you click on the "Add Zone" button a new one is added to the list. It will always be
one greater than the last zone shown in the list.

Deleting a Zone
When the user clicks on the "Delete Zone" button, the selected zone in the list is removed.

Changing a Zone Border Colour
To use this option you must first select a zone from the list displayed.
By clicking on the button with the line, the user will be able to select a line style in which the
border of the selected zone will be displayed.

Use style for link isochrones
If you tick this box then the line style used above is used when generating link based
isochrones.

Changing a Zone Fill Pattern
To use this option you must first select a zone from the list displayed. 
By clicking on the button next to the line style button the user will be able to select a fill
pattern for the selected zone.
You can have separate styles and values for Drive Time and Drive Distances.

Doughnut polygons
When this option is checked then the overlaying polygons are cut from larger polygons.
This results in polygons that represent "bands" of time between two values, i.e: 0-5, 5-10
and 10-15. Otherwise 0-5, 0-10 and 0-15 polygons are generated.

Smooth Isochrones
This option will remove a lot of the spikiness of the voronoi and polygon isochrones to give
them a more rounded look and feel. This do slightly reduce the overall accuracy of the
resulting polygons. Also there are some circumstances when using the voronoi type
polygons that gaps may appear between polygon vertices. It is up to the user to decide
when to use them and when it is inappropriate to use them. Service Area polygons are not
smoothed.
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Normal Voronoi Isochrone

Smoothed Voronoi Isochrone

 

Retain Holes / Retain Island
This option will allow you to alter the look of your isochrones. If you unselect the retain
holes option then any areas within the main isochrone that cannot be reached (because of
the time or distance setting) is ignored. The same is true if you unselect Retain islands.
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While this makes the isochrones aesthetically pleasing, it can lead to misleading results and
so you use this at your own risk.

Normal Voronoi Isochrone with Holes

Voronoi Isochrone with holes removed
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Accuracy
The accuracy option will determine how the voronoi drive time boundaries and service area
polygons are created. The same settings are used for both isochrone methods and is
explained here:

During calculations additional nodes can be added dynamically along the links, so long
links will get more nodes added, while shorter links will not. You can define the approximate
additional nodes to have added compared to the initial number of nodes:

Most: 6 times more nodes.
Average: 3 times more nodes.
Least: No additional nodes (default).
Custom: Enter a number corresponding to the number of additional nodes you want (in the
same way as above).

The larger the number, the more RAM is needed and the requirements increases fast, so
don't just type in a very big number.

Most – The isochrone will reflect very accurately the extents of the boundaries using every
link in the network. This results in very jagged looking boundaries.
Average – This will generalize some of the spikes to produce a smoother looking polygon.
Least - This will generalize some of the spikes to produce a much smoother looking
polygon.
Custom - This is automatically set to be the most accurate isochrones possible. The
additional nodes do not affect this function in any other way.

Use Selective links
You can use this option to control which links are used for generating voronoi isochrones.
This can allow you to produce nicer looking isochrones. The images below show the effect
of leaving out some of the links:
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Isochrone using all links

Isochrone with the major road links not considered
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So in the above image you will see that along the major road some small part of the
isochrone are generated around its nodes. This can make them look untidy. So if the user
tells RouteFinder not to use the major road links unless they form a part of the main
isochrone. The result is a nicer, more understandable isochrone.

To use this option you would add a smallint field to your network table. You would update
all the records to equal 1. Then those links you want to exclude from the isochrone
generation you would mark with a 0 (zero).

In the dialog you would click on the checkbox to enable "Use Selective Links". Then you
pick the column from the network table that contain the 1 and 0's. They will automatically be
reloaded the next time the network is loaded if used.

Clip Polygons
This allows the clipping of polygons to another table, for instance a coastline, and will give
a nicer presentation of the result. See the images below to see the difference in the options.
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Drive time polygons not clipped  / clipped to the coastline.

This setting applies to Drive Time Polygons and Service areas.
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2.6 Travelling Salesman Options

Go to Options > TSP 

RouteFinder has a number of options for the Travelling Salesman routine:

Round Trip 
This is the default option. The route will Start and finish at the first point you click on the
map / found in your table.

Start-End Point 
The route will start at the first point and finish at the last point. The order of the points in
between are optimised.

Start-Point only
The Route will start at the first point and the order of the rest of the points are optimised.
You will typically end at a point far away from the start point with this option (but not
always).

End Point Only
The Route will end at the last point and the order of the rest of the points are optimised.
You will typically start at a point far away from the end point with this option (but not
always).

Fully Open Solution
This will start and end at any location that has been entered.
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2.7 Program Options

Go to Options > Program 

This will set defaults for the way the program will work. It will then use the same settings no
matter what network is loaded. When clicked you will see the following dialog.

Store network in Memory
When you use this option most of the network binaries are stored in RAM. This can lead to
faster calculations but may run slower on computer with limited RAM. The easiest way to
estimate the amount of RAM required is to look at the file sizes of the BIN files in the folder
with the network.

Keep Interactive Results
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This feature will not delete the result from an interactive measurement or Isochrone
calculation automatically. This will allow you to show multiple results from the interactive
tools. You will need to click on the Clear Current Result  button to clear the map.

Display Time as Hr Min Secs
By ticking this option the time will be displayed in a string format rather than a decimal
format. i.e 81.746 mins becomes 1h 21m 44s. This will make time more understandable but
is not so easy sort into numerical order. In batch functions you will get both decimal and
string format times if this option is used.

Allow points outside of Network area by X %
This option will check that the coordinates specified by clicking in the map window or
specified by input files are within the Minimum Bounding Rectangle + X % of the street
network. e.g If the coordinate should be between 0 and 50 and Coordinate Window=20%,
then only coordinates between -10 and 60 will be accepted. By setting Coordinate Window
< 0, the check is disabled. This will prevent situations where you, by mistake, swap x and y
coordinate or use lat/long coordinates when the street network was in a projected
coordinate system or vice-versa.

Currency Symbol
We now use three letters to represent  a currency. I.e GBP = Great British Pound, DKK =
Danish Krone or USD = US Dollar. You can find a list of codes at
https://www.iban.com/currency-codes

Display Settings
You can set the default style for various line style and Points styles that are used when turn
restrictions are used. These should be set before importing or adding restrictions to your
network.

2.8 Performance

RouteFinder can perform many different kind of calculations and it is difficult to give broad
indications of performance, because it depends upon many factors:
· Size of network
· Size of input files and geographic distribution of objects
· etc.

However, generally these settings have a negative impact on performance:

Route options:
· When avoiding no-through roads
· When using turn restrictions

Drive time options:
· When setting accuracy high

Many functions:
· When adding route objects to the output
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2.9 Open Sample Folder

Go to Open Sample Folder 

The sample folder contains OpenStreetMap sample data, which have been setup for
illustrating various elements of RouteFinder.

2.10 Open Settings Folder

Go to Open Settings Folder 

This option can be used to open a folder with various files, that are updated by the
application.

The license file is stored here (generated when you enter a serial number).

The error log file contains any errors that have been generated by RouteFinder and can be
useful in helping the support to determine problems or bugs in the program.

You will also see the RouteFinderOptions.ini file.
This file should not be edited unless asked to do so by any support request.

When you select this menu item you will see something similar to this:

2.11 New Serial

When using a demo, time limited or link limited license, it is possible to upgrade to a full
version at any time.

By clicking on the "New Serial" button, you will see the following dialog:
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Enter the serial number that will have been supplied and click on the OK button.

Your new license should then be activated.



Interactive Tools

Part III
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3 Interactive Tools

The tools in this section are used by clicking in a map window when the network has been
loaded.

Routes can be generated with:
· Route  - can have driving directions
· Travelling Salesman  - can have driving directions

Single or Multiple Isochrones can be generated with:
· Link Isochrone
· Simple Isochrone
· Voronoi Isochrone
· Graduated Isochrone
· Service Area

Various other functions:
· Update Point File
· Traffic Volume

3.1 Route

Click to add starting point. The word "Start" will appear on the map. 

Use the Ctrl-Click to add via's. The number of the via will then appear on the map. 

Shift-Click to add the last point. The word "Finish" will appear on the map.
 
The route is then calculated and displayed on the map. Using the "Route Options " on
the Options Group can change the style of the line used to display the route

The time and distance (and optionally direct distance and cost) is displayed in the message
window

An example route is shown below.

56

57

58

59

60

61

62

63

65

34



57Interactive Tools

© 2023 Higher Mapping Solutions & RouteWare

To create routes based on points already recorded in a table, refer to either Select
Locations  or other batch functions.

3.2 Travelling Salesman

This function will show the optimised route between a series of points. For different modes
of operations, see here .

The points are entered interactively in the same way as in function Route .

Click to add starting point. Use the Ctrl-Click to add more points.

The word "Start" will appear on the map. A small diamond represents the points.

Then Shift-Click to add the last point. Then the optimal route is calculated through all the
points.

The points are labelled to show the order in which to visit them.
An example of this is shown below.
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3.3 Link Isochrone

This function will create a new table, that shows drive times or drive distances from a point
on the map.

After selecting this tool you need to click on the map that represents the start location. To
do more than one isochrone just hold the "ctrl" key while clicking with the mouse button. To
produce the isochrones hold the "shift" key down while clicking for the last Isochrone.

Link based isochrones has their origin at a network node if you select multiple starting
points. If a single starting point, it uses exact mode.
Actual drive-time steps are using dynamic segmentation.

An example link isochrone is shown below:
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The result will be stored in a layer called "IsoLink"

3.4 Simple Isochrone

This is the fastest method for doing drive time polygons and less demanding on processing
power. The drawback is it doesn't produce as accurate results as the voronoi method
and it can't create a single output layer for multiple centers with the interactive tools.

To do a single isochrone you simply click on the map. To do more than one isochrone just
hold the "ctrl" key while clicking with the mouse button. To produce the isochrones hold the
"shift" key down while clicking for the last isochrone.

You define the polygon setting through the Drive Time Options  menu, where the
spikiness of the isochrones can also be changed.

An example is shown below:
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3.5 Voronoi Isochrone

This is the most accurate of the 2, but also most demanding on processor time and RAM
requirements. It is based on creation of voronoi boundaries.

To do a single isochrone you simply click on the map. To do more than one isochrone just
hold the "ctrl" key while clicking with the mouse button. To produce the isochrones hold the
"shift" key down while clicking for the last Isochrone.

You define the polygon setting through the Drive Time Options  menu.

An example is shown below:

42
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3.6 Graduated Isochrone

This is a new isochrone for version 6 and is also demanding on processor time and RAM
requirements. Unlike the other type of isochrone this have no hard borders. 

To do a single isochrone you simply click on the map. To do more than one isochrone just
hold the "ctrl" key while clicking with the mouse button. To produce the isochrones hold the
"shift" key down while clicking for the last Isochrone.

You define the polygon setting through the Drive Time Options  menu.

An example is shown below:

42
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:

3.7 Service Area

This function can be used to show polygons representing the parts of the road network that
is closest to a number of designated outlets. It can be used as a first pass territory planning
system.

Click to add starting point. A small diamond represents the point. If the clipping  options
have been set then this layer will also be clipped using the selected layer.

Use the Ctrl-Click to add more points.

Then Shift-Click to add the last point.

48
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The result will be stored in a layer called "ServiceAreas"

3.8 Update Point File

This function can be used to perform a quick update of a point table with distances and
times to a point on a map.

After selecting this tool you need to click on the map that represents the start location.

The following dialog is displayed showing all the open tables:
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From the drop down box select the tables that you want to add the time and distance.

If your table does not have the columns to hold the result - you will be prompted to add
them:

Once the process is completed the table will have RF_Time and RF_Dist added.
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3.9 Traffic Volume

This function will allow you to calculate how many times an individual link is used, when
routing to a single location from a number of points stored in a table.

After selecting this tool you need to click on the map that represents the start location.

The following dialog is displayed showing all the open tables:

From the drop down box select the tables that you want to use.

You can also decide how to calculate the volume on a particular link. The default is just to
count 1 each time the link is used. The second option is to use a column in your table to
calculate the volume on a particular link. In this way you might apply a weighting to the
sources of traffic.

An example of this is shown below:
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3.10 Clear Current Result

This function will close all temporary results generated by RouteFinder (not just routes -
also isochrones etc.) and clears the results from the message window.



Batch Jobs

Part IV
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4 Batch Jobs

This is a collection of functions which all require one or two tables as input.

The tables need to contain (mostly) point objects.
They should be packed.
All records should be geocoded (except for "Route Pairs by coordinate").
They can be in any coordinate system (except for "Route Pairs by coordinate").
Typically there need to be some kind of ID field.

Large scale matrices
Distance Matrix  (2)
Nearest N centres  (2)

Route Pairs
Route Pairs  (2)
Route Pairs by coordinate  (1)

Routes with possible driving directions
Travelling Salesman  (1)
Batch TSP routes  (1)
Select Locations
Route on a Joined Table by ID

Snapping to network
Allocate point to network  (1)

Isochrones etc
Drive Times / Service Area  (2)
Drive Time from column  (2)

It also applies to these interactive tools
Update Point File  (1)
Traffic Volume  (2) 

(1) = Only possible with native tables with write-access.
(2) = Can also use query tables as input

4.1 Distance Matrix

Go to Batch > Distance Matrix 

This function will allow generation of a matrix showing time and distance between a number
of points. For example, depots to outlets.

The following dialog is displayed:
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1. Select the table from the drop down list in the "From" box
2. Select the column that contains the identifiers (e.g. ZIP code, name etc.)
3. Repeat the selections from the "To" box

If the tables are the same you will have the option of calculating the routes in both
directions. i.e. Town1 to Town2 and Town2 to Town1

The default is to calculate in one direction only.

You can also decide to not build the mappable routes. This option runs more quickly and
will create a smaller route results table.

If you are trying to generate a large matrix the you can use the CSV output option. This will
get over the 2GB limitation for MapInfo tables, however you will not be able to produce
route objects.

You can enter a maximum value for the calculation. Any result greater than this value will
not be included in the results.



70 RouteFinder 6.05 for MapInfo

© 2023 Higher Mapping Solutions & RouteWare

You can input a path and table name and the output will be saved to this location. You can
also click the button "..." and you will be able to navigate to a folder and input a file name.

If the table contains invalid objects or has deleted rows then you will get one of the
following messages:

If some points fail to load you will see the following message:

In the message window you will see the errors listed
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If you have asked for the Route Objects to be created, then the following message is
displayed:

Then you will see the results:

The distance column will be in the currently selected distance unit, either miles or
kilometers. The time will always be returned in minutes.

Route Directions cannot be generated with this option.
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If you have used the output to CSV option then you will see a message informing you of the
output location.

NB: It is quicker to use this function by having the smaller table as the origins and
the larger table as the destinations. You can decide if this makes a difference to the
calculation you are attempting.

4.2 Nearest N Centres

Go to Batch > Nearest N Centres 

This function is useful for calculating the time and distance from a location until "Nearest"
locations on the list has been reached. 
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Origin Table
Use the drop down boxes to select the table and the column to use as the identifier.

Centres Table
Use the drop down boxes to select the table and the column to use as the identifier. This is
then used by the function to get the nearest centres depending on the limits entered.

For efficiency routes are calculated from centres to origins, because there are normally
many more origins than centres.

Therefore you may want to set "Reverse"  in the route options to take into account the
one way street direction.
This will however not reverse turn restrictions. If is important for you to calculate routes to

the centers and have turn restrictions, you should use the Matrix  function instead and
then do your own post-processing of the output (sorting and filtering).

Number of Nearest Centres
If a number is entered in here then the function will find the nearest centres until this
number is reached. You cannot specify more centres than are in the destinations table.

34
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Time Limit
If a number is entered into this box then it is used to find the nearest centres within the time
limitation.

Build Route Object
If you use this option then you will get routes that can be displayed on a Map.

Export to CSV File
If you are trying to generate a large matrix the you can use the CSV output option. This will
get over the 2GB limitation for MapInfo tables.

You can input a path and table name and the output will be saved to this location. You can
also click the button "..." and you will be able to navigate to a folder and input a file name.

You can combine the two limits together to say find the nearest 10 centres and within 20
minutes of the origin. You should realise that this may return less centres than specified in
the "Number of Nearest Centres" box.

You will get a message if that tables you select have deleted rows or have records that are
not geocoded.
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When the process has finished you will get a table like this:

If you have used the output to CSV option then you will see a message informing you of the
output location.
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4.3 Select Locations

Go to Batch > Select Locations 

This function will allow the user to select the start location, any via's and the end
destination point from a gazetteer. This will allow users to specify Norwich as a start point
and Masons Island as the end point. The system will then produce a route from one to the
other.

The following dialog is displayed:
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1. Select the table from the drop down list.
2. Select the column that contains the identifiers (e.g. Town)
3. Type in the name of the first location. 

You may need to allow any column used to be index in order for this option to find it

4. Click on the "Add" Button. If the location is not found in the table then close matches
are displayed for the user to select from

5. The location is displayed in the list box. 
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6. Repeat steps 3-5 to add locations. At least two must be selected.
7. Select between generating a "Route" and/or optimizing the route between the selected

points.
8. Click on the OK button and the locations are processed and displayed on the map.
9. If you add a location by mistake then you can select the location from the list box and

then press the Delete button.

4.4 Route Pairs

Go to Batch > Route Pairs  

This function will allow routes to be generated between two points in different tables. The
number of rows in each table must match for this function to work. When used the first row
from table one is selected as the start point and the first row in the second table is used as
the end point.

When selected the following dialog is displayed:
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1. Select the first table from the drop down list in the "From" box
2. Select the column that contains the identifiers (e.g. ID)
3. Repeat the selections from the "To" box for the second table

If you are trying to generate a large matrix the you can use the CSV output option. This will
get over the 2GB limitation for MapInfo tables, however you will not be able to produce
route objects.

You can input a path and table name and the output will be saved to this location. You can
also click the button "..." and you will be able to navigate to a folder and input a file name.
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You will get a message if that tables you select have deleted rows or have records that are
not geocoded.

The other option is to build map objects of each of the routes generated. If you use this
option then before the results are displayed you get the following question:
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By selecting "Yes" the routes will be added to the map.

The results will look like:

The distance column will be in the currently selected distance unit, either miles or
kilometers. The time will always be returned in minutes.

Route Directions cannot be generated with this option.

If you have used the output to CSV option then you will see a message informing you of the
output location.
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4.5 Route Pairs by Coordinate

Go to Batch > Route Pairs by Coordinate   

This function will allow routes to be generated between two points defined as coordinates
in one table, using the same coordinates as the roads table.

For instance if you have a table with two sets of coordinates like this:

When you select Route Pairs by Coordinate you are prompted to select the table to use
and the columns you want to use to produce a route between:
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.

This function requires suitable columns in your table to hold the result. If they are not
present then you will be asked permission to add these columns.
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Press OK to continue the process.

You can also decide to not build the mappable routes. This option runs more quickly and
will create a smaller route results table.

If you do select this option, you will be prompted to make the table mappable, if it is not
already mappable.

After processing if you have asked for routes to be produced, you will be asked if you want
to see them on the map:

Finally a browser is displayed with the result.
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4.6 Route on a Joined Table by ID

Go to Batch > Route on Tables Joined by ID 

This function will take two tables as the input that have a common ID field between them.

When selected the following dialog is displayed:
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From section

Table - The origin point locations
ID column - The identifier column to use for each origin
Join Column - The name of the field that joins with the destinations table

To section

Table - The destination point locations
ID column - The identifier column to use for each destination
Join Column - The name of the field that joins with the origins table

You can also decide to not build the mappable routes. This option runs more quickly and
will create a smaller route results table.

If you are trying to generate a large matrix, then you can use the CSV output option.

This will get over the 2GB limitation for MapInfo tables, however you will not be able to
produce route objects.

You can input a path and table name and the output will be saved to this location. You can
also click the button "..." and you will be able to navigate to a folder and input a file name.
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You will get a message if that tables you select have deleted rows or have records that are
not geocoded.

If you decide to generate map objects of each of the routes generated then you get the
following question:
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By selecting "Yes" the routes will be added to the map.

The results will look like:

If you have used the output to CSV option then you will see a message informing you of the
output location.
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4.7 Allocate Point to Network

Go to Batch > Allocate Point to Network 

This function will allow a point file to be allocated a unique link ID value or moved to the
nearest link on the network.



90 RouteFinder 6.05 for MapInfo

© 2023 Higher Mapping Solutions & RouteWare

The first option is to choose the Point table you want to allocate. Then you need to decide
what actions you want to do.

The first is to get the reference column from the road network table and put it into you point
table. eg a street name.

Column to update
This is a column in your point table

Reference column
This is a column in the network table.

You can validate the points so they are only updated if one column in the network table
matches that in the point table being used. Eg the street names have to be the same.

Check this column from the point table
Use this column in your point table as a reference to check the link in you network table.

Has the same value as this column from the network table
This is a column in your network table - it will be checked against the point being allocated.
If the references are the same the columns will be updated.

Move Point to nearest link
By checking this option the point will be updated with the new coordinates of the nearest
point on the link. 

Add distance to table
This option will add the "DisttoNetwork_km" or "DisttoNetwork_Mi" column to the point table
indicating the distance of that point to the nearest link on the network. If the column does
not exist then you will be prompted to add it.

Add side of the road 
This option will add "SideofRoad" to the point table. If the column does not exist then you
will be prompted to add it.
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0 =  Right side of the road
1 =  Left side of the road

Ignore points further away than
If the distance from the point to the nearest link is greater than the distance specified in the
box then it is ignored.

You will get a message if that tables you select have deleted rows or have records that are
not geocoded.

When the process is completed a browser is displayed with the result.
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4.8 Drive Times / Service Area

Go to Batch > Drive Time - isochrones 

This function will allow generation of multiple polygon or link based drive time or drive
distance polygons.

The following dialog is displayed:

The first step is to select a table of point objects from which to produce isochrones.

There are 4 options available in the Batch Drive Time (or drive distances). 

The first option is to generate Voronoi based Isochrone polygons. 

This next option is standard polygon isochrones. The style of these polygons is set using
the Drive Time  (or Drive Distances ) option. 

With the first two options you also have a choice of overlapping or non-overlapping
polygons. If you want the isochrones to overlap then you check the "overlap" box.

Here is an example of an overlapping Isochrone:
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And in this example there is no shared area they are merged together.
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Link drive time or distances will shade the links on the network according to the values set
up in the options dialog. These are non-overlapping by nature.

The last option in this dialog is to generate a map of service areas  polygons. These are
non-overlapping by nature.

For the polygon options, you can also select a column name to work with the function. This
will then update the polygons that are created with the value of the selected field for each
point. This will allow you to easily identify which polygons have been created for each point
on your map.

You can input a path and table name and the output will be saved to this location. You can
also click the button "..." and you will be able to navigate to a folder and input a file name.

62
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4.9 Drive Time from Column

Go to Batch > Drive Time from Column 

This function will allow generation of multiple polygon or voronoi based isochrones that are
based on a distance or time for each point. The time or distance is set in a column in a
table.

The following dialog is displayed:

1) Select a table from the "Table" drop down menu of point objects from which to produce
isochrones. 

2) Select a column from the "ID Column" to use to Identify each isochrone generated.

3) Select a numeric column which contains the required drive time or distance for the
isochrone.

N.B if no numeric columns are in the selected table then the OK button will be greyed out
and you will not be able to continue the process
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Part V
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5 Optimise

5.1 TSP from table

Go to Optimise > TSP from Table 

For this function the table selected is optimized and the result is displayed on the map. The
order in the table is used as the start and end points. See the explanation of the options in
the Travelling salesman  button option. If you select the "Points already optimised" option
then a route will be generated based on the order of the points in the table.

1) Select the table to use for the calculation
2) Select if you want to add a delay at each stop point.
3) If so, click the "Add delay at each stop" check-box.

i) If you have a column in your table to determine the time at stop at each point you
can select that by using "Delay Column"

ii) Otherwise you can define a standard stop time at each stop by putting a value in
the box.
4) If your point are already in the order that you want a route to be produced then simply
select the "Points already optimised" check-box

If your table does not have a column to store the result then you will see this prompt:

57
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If you click "Yes" then the column is added as an integer column.

You will get a message if that tables you select have deleted rows or have records that are
not geocoded.

The result of the TSP is stored in this column
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Afterwards any results are displayed on the map.

How to create a table suitable for Travelling Salesman:
If you need to define your start and/or the end points then you should build a new table from
the one that you want to optimize. Here is one way in, which this could be achieved:

1. Select the point you want to start with from the map or from a browser. 
2. Use File > Save Copy as.. and save the selection to a new table.
3. Open the new table.
4. Next Select all the records from the target table and use the shift key and click to

de-select the start and/ or end points.
5. Use Table > Append Rows to Table to add the selection to your new table.
6. Select the point you want to end with (if required) and use the Append Rows to

table to add to your new table. Save your new table and you are then ready to do
the optimization with the table you have built.
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5.2 Batch TSP Routes from table

Go to Optimise > Batch TSP from Table  

This option will take a table of points and produce optimized routes based on an ID column
in the selected table. The program will select out each ID and use the first and/or last points
in the selection as the start and end points. You can optionally select a further column to
order the points so you can force the use of the start and end points. See the explanation of
the options in the Travelling salesman  button option. If you select the "Points already
optimised" option then a route will be generated based on the order of the points in the
selected set of ID's.

If your table does not have a column to store the result then you will see this prompt:
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If you click "Yes" then the column is added as in integer column. The result of the TSP is
stored in this column in the original table.

You will get a message if that tables you select have deleted rows or have records that are
not geocoded.

Each record will have a route attached to it that can be mapped. if so you will see this
message:

When the process is completed a new table is created called "BatchTSPResults" and the
results displayed in a browser.
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5.3 Cluster 1 Analysis (capacity)

Go to Optimise > Cluster 1 Analysis (capacity)

This function solves the problem of clustering customers into clusters with a given
capacity, so total distance between cluster center and customers is minimized, while
capacity is respected. An optional weight can be also be taken into account. It is aimed at
sorting different objects into meaningful groups.

Parameters

You first need to pick the point table you want to use.

You can select a column that represents the demand for each point. For instance a point
might represent a different number of survey points.
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If a specific column is not selected then each point will have a default demand of 1.

Next you have to input the capacity of the clusters you would like the function to produce.
You can also select the option to show the centre point of each group just tick the box.

The higher the capacity, the less clusters are produced.

Calculation type

The cluster algorithm uses a matrix in order to work. This can be a straight line or a
calculated route distance. The straight line is very quick but is not as accurate as a routed
distance, There is an example below.

Click OK to perform the calculation.

If you have selected the route matrix type then you might see the following progressbar.

If your table does not have a column to store the result then you will see this prompt:

If you click "Yes" then the column is added as in integer column. The result of the clustering
is stored in this column in the original table.
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You will get a message if that tables you select have deleted rows or have records that are
not geocoded.

 

Otherwise the calculated groups will be displayed.

Performance

If you are using a uniform demand of 1, then a more advanced method is used, which gives
very good results, but is slower than with non-uniform demand. For instance if you use the
sample data and the 1000 students, grouped into clusters with a capacity of 100, it takes ~
15 minutes to get a result.

5.4 Cluster 2 Analysis (N clusters)

Go to Optimise > Cluster 2 Analysis (N clusters)
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This function solves the problem of clustering customers into N clusters, so total distance
between cluster center and customers is minimized. An optional demand can be also be
taken into account. It is aimed at sorting different objects into meaningful groups.

Parameters

You first need to pick the point table you want to use.

You can select a column that represents the demand for each point. For instance a point
might represent a different number of survey points.

If a specific column is not selected then each point will have a default demand of 1.

Next you have to input the number of centres (i.e number of groups) you would like the
function to produce. You can also select the option to show the centre point of each group
just tick the box.

Calculation type

The cluster algorithm uses a matrix in order to work. This can be a straight line or a
calculated route distance. The straight line is very quick but is not as accurate as a routed
distance, There is an example below.

Click OK to perform the calculation.

If you have selected the route matrix type then you might see the following progressbar.

If your table does not have a column to store the result then you will see this prompt:
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If you click "Yes" then the column is added as in integer column. The result of the clustering
is stored in this column in the original table.

You will get a message if that tables you select have deleted rows or have records that are
not geocoded.

 

Otherwise the calculated groups will be displayed.
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Cluster analysis using straight line (A)   
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Cluster analysis using routes (B)

You can see that using straight line can produce compact groups, but they do not take into
account natural barriers such as rivers. On the (B) picture blue and screen dots are better
separated by the water.

5.5 Location to Facility

Go to Optimise > Location to Facility
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This function solves the problem of clustering customers, so the load within the cluster is
lower than am defined capacity and geometric size of cluster is minimized.

Parameters

You first need to pick the point table you want to use as the source. This could be students
that need to be allocated to schools or even sales potential to regional offices (sales areas).

You can select a column that represents the demand for each point. For instance a point
might represent a different number of students or sales value.

If a specific column is not selected then each point will have a default demand of 1.

Next you need to pick the facilities table. This could be schools or sales offices for
instance. 

Then you need to select a column that identifies the facility.

Finally, select the capacity of the facility.

Calculation type

The cluster algorithm uses a matrix in order to work. This can be a straight line or a
calculated route distance. The straight line is very quick but is not as accurate as a routed
distance, There is an example below.

Click OK to perform the calculation.
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If you have selected the route matrix type then you might see the following progressbar.

If your table does not have a column to store the result then you will see this prompt:

If you click "Yes" then the column is added as in integer column. The result of the clustering
is stored in this column in the original table.

You will get a message if that tables you select have deleted rows or have records that are
not geocoded.

Otherwise the calculated groups will be displayed.
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Location to facilty using straight line
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Location to facility using routed calculation

A legend will be displayed showing the results of the calculation

5.6 Centre of Network

This option will calculate a centre point of a network. It will take the longest route in the
network and give the halfway point.
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It then marks that location on the network.
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6 Restrictions

You can manage restrictions through the user interface. This includes turn restrictions, one
way streets, height, width and weight restrictions.
You can also manage "avoid" bits, closing roads and slowing roads.

You can make changes to the network, but they are only permanently applied to the
network if you save the restrictions.

The functionality is accessed via the Restrictions menu item.

6.1 Import Turn File

Go to Restrictions > Import Turn File 

This options will take a text file of predefined turn restrictions and create the binary files for
use in RouteFinder.

If turn restrictions are currently being used then you will be asked if you want to overwrite
the existing restrictions.

The first step is to select the text file containing the turn restrictions.
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Turn files are simple text files made up of lines line this:

1 390 391 -1
1 258 259 -1
1 609 797 -1

The first number is the restriction type; the next two are the rowids of the network to create
a restriction and finally the type of restriction. 

However you can use an external ID if you specify the unique reference column when
creating the network  then they might look like this:

0 rowid_6535 rowid_16558 -1
0 rowid_7654 rowid_6474  -1
0 rowid_2183 rowid_9547  -1

The -1 is the cost value and indicates it is a banned turn. Here is a list of valid restrictions
that RouteFinder can read from a text file:

0: Simple Turn restriction, 2 external link ID's + 1 cost value 
1: Simple Turn restriction, 2 link ID's + 1 cost value 
2: TurnStandard, coordinates for node 
3: Mandatory turn, 2 external link ID's 
4: Mandatory turn, 2 link ID's 
5: Complex Turn restriction, >2 external link ID's + 1 cost value 
6: Complex Turn restriction, >2 link ID's + 1 cost value
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If you use turn restrictions with external ID's (type 0, 3 and 5) make sure you have specified
an external ID column or you will get an error returned. Type 0, 2, 3 and 4 gets translated
into one or more type 1 during import and type 5 gets translated into type 6 during import.

If you press cancel to the importing of turn restrictions then you will be notified of the import
of one way streets and also any height, width and weight restrictions that have been set up
at the network creation phase.

Once the process have completed you are asked if you want to see the restrictions on the
map.

6.2 Displaying One Way Streets

If your data set does not have turn restrictions, but you still want to show the one way street
direction, then you can do this clicking on the Import Turn File button. When you are
prompted for a turn.txt file as shown below:
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Click on the "Cancel" button and you should see a prompt asking if you would like to import
one way streets and any road restrictions that may have been defined on your network:

If you click the "Yes" button then your network will be scanned and any one way streets will
be displayed.

6.3 No Turn

Go to Restrictions > No Turn 

You can add turn restrictions manually to the network. You first click on the "No Turn"
button.

To add a restriction, click on the map and hold the button down. You then draw a line
between the two links, that you want to set a no turn restriction.
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Next a line is displayed showing the direction in which you can travel. 

The restriction is applied immediately, but they are only permanently applied to the network
if you save the restrictions .

6.4 One-Way

Go to Restrictions > One Way 

You change or remove a one-way street on the network. You first click on the "Change
One-Way" button.

Click on the link and the restriction will swapped or will be removed totally.

A line is displayed showing the direction in which you can travel. 

For instance we take a normal link in which you can travel in both directions, then it will
work like this:

One way in digitised direction,

135
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then one way in opposite digitised direction:
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If the link is clicked again then the restriction is removed.

The restriction is applied immediately, but they are only permanently applied to the network
if you save the restrictions .

6.5 No Through Roads

Go to Restrictions > No Through Roads  

You can set a link or links to be considered as no through roads. That is a link where a
route can be start or finish but it cannot be complete traversed.

This tool will change the attribute column in the network table.

 Click the "No Through Roads" option and then click on the link. If you have the Show
Restrictions  on then you will see a no though roads symbol on the map.

You should note that the restriction is applied to the whole link and not just the place that
you clicked.

The restriction is NOT applied immediately, but they are only applied to the network, if you
save  the restrictions.

6.6 Set Avoids

Go to Restrictions > Set Avoids 

You can change the avoid value of link(s) by using the tool "Set Avoids" option in the
restriction group. This tool allows you to manage using your network for different uses.

135
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For instance you may decide Avoid 1 is motorways and so you would select "avoid 1" to be
part of vehicle type for walking.

Similarly you may want Avoid 2 to be footpaths and so you would select "avoid 2" to be part
of motorized vehicle types.

This tool will only work if you have specified an "Avoid Column" when creating a network
.

To use the tool you must first select one or more records from your network table. This can
be done interactively on the map or through a query.

When you have a selection, you then click the "Set Avoids" option and you will  see the
following dialog:

The group of tick boxes will show which avoids for the link. To not use the link for a certain
avoid setting, simply tick the box for that Avoid. You can also change the description for any
of the items by clicking on the appropriate button at the end of each description. When you
click on one of these buttons, you are prompted to enter the new name:

When you have entered the new name and press OK then this is reflected on the dialog.
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This name will then be used in other areas of RouteFinder such as the Route Options
Dialog.

The restriction is applied immediately, but they are only permanently applied to the network,
if you save the restrictions.

6.7 Attribute Calculator

Go to Restrictions > Attribute Calculator  

This option will change the attribute or one or more links, including the road class. It can be
used to more easily manage what links are used for.

To use the tool you must first select one or more records from your network table. This can
be done interactively on the map or through a query.

When you have a selection, you then click the "Attribute Calculator" option and you will  see
the following dialog:

34
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Single Link Multiple Links

You can now change the road class and the link attributes and that change will be applied
to all the selected links.

The restriction is NOT applied immediately, but they are only applied to the network, if you
save  the restrictions.

6.8 Height

Go to Restrictions > Height 

You can add height restrictions manually to the network. You first click on the "Height
Restriction" menu item.

When you click on the link you want to apply the height restriction you will be prompted to
enter a value (0 - 25.5 meters).
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When you click OK the restriction is shown on the map.

You should note that the restriction is applied to the whole link and not just the place that
you clicked.

The restriction is applied immediately but they are only permanently applied to the network,
if you save  the restrictions.

6.9 Width

Go to RouteFinder TAB > Restrictions > Width 

You can add width restrictions manually to the network. You first click on the "Width
Restriction" button.

When you click on the link you want to apply the height restriction you will be prompted to
enter a value (0 - 25.5 meters).
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When you click OK the restriction is shown on the map.

You should note that the restriction is applied to the whole link and not just the place that
you clicked.

The restriction is applied immediately, but they are only permanently applied to the network,
if you save  the restrictions.

6.10 Weight

Go to Restrictions > Weight 

You can add weight restrictions manually to the network. You first click on the "Weight
Restriction" button.

When you click on the link you want to apply the height restriction you will be prompted to
enter a value (0 - 127.5 tons).
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When you click OK the restriction is shown on the map.

You should note that the restriction is applied to the whole link and not just the place that
you clicked.

The restriction is applied immediately, but they are only permanently applied to the network,
if you save  the restrictions.

6.11 Change Road Speed

Go to Restrictions > Slow Road Speed 

You can change the speed of a link, thereby overriding the default value by clicking on the
"Change Road Speed" menu item and then clicking on a link in the road network.

When you click on the link you want to apply the new road speed you will be prompted to
enter a value.
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When you use this tool you will see a new sign appear on the map:

You should note that the restriction is applied to the whole link and not just the place that
you clicked.

The restriction is applied immediately, but they are only permanently applied to the network,
when you save  the restrictions.

6.12 Close Road

Go to Restrictions > Close Road 

You can close a road manually on the network. You first click on the "Close road" button.

This will immediately close the roads.

When you use this tool you will see a no entry sign appear on the map.
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You should note that the restriction is applied to the whole link and not just the place that
you clicked.

The restriction is applied immediately, but they are only permanently applied to the network,
when you save  the restrictions.

6.13 Fixed Time

Go to Restrictions > Fixed Time  

You can change the speed of a link, thereby overriding the default value by clicking on the
"Fixed Time" menu item and then clicking on a link in the road network.

When you click on the link you want to apply the new fixed time you will be prompted to
enter a value.

When you use this tool you will see a new sign appear on the map:
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You should note that the restriction is applied to the whole link and not just the place that
you clicked.

The restriction is applied immediately, but they are only permanently applied to the network,
when you save the restrictions.

6.14 Show Restrictions

Go to Restrictions > Show Restrictions 

When you click on this button it will show or hide any turn restrictions, one way streets  and
any height, width or weight that are on the current network.

See also Displaying One Way Streets .118
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To show roads that are being avoided then use the show closed roads
6.15 Show Closed Roads

Go to Restrictions > Show Closed Roads 

This option will show the closed roads for the current set of avoids that is set for the
network.
It will also show any roads that are not useable for the current vehicle properties, if they
have been set in Route Options .

132
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The roads not available with the current settings are shaded with a red line with crosses.

6.16 Delete

Go to Restrictions > Delete 

This tool will delete the selected Restriction.

First of all use the select tool to pick a restriction from the map (The restrictions layer must
be selectable).
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Then click on the "Delete Restriction" button - you will be prompted to confirm the deletion.

When you click OK, then the restriction is removed.
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This will remove any restriction except for one-way streets or any avoid settings for that
link. You will need to use the "Change One Way " tool or "Set Avoids " tool to remove
any changes to a link.

The restriction is deleted immediately, but they are only permanently applied to the network,
if you save  the restrictions.

6.17 Save

Go to Restrictions > Save 

Click this button to save any restrictions that have been added or editing.

When pressed you will be asked to confirm if you want to save or discard your changes.

120 122
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If you click discard then any edits to the restrictions are not applied to the network and the
edit are discarded.

If you save your restrictions then depending on what you changed you will update the
following files:

Restrictions.tab
Any banned turns, height, width, weight ,closed roads, slowed roads, one way streets that
are added or deleted.

The network table
The attribute column could be updated if you change a one way street.
The avoid column could be updated if you have change any links.

Limit1.bin: Holds the links that have avoids set.
Limit2.bin: Height restrictions.
Limit3.bin: Width restrictions.
Limit4.bin: Weight restrictions.
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7 Network Analysis

Included is a number of functions that allow the network to be analysed for topology and
connectivity. For possible bug fixing.

It can also assist in removing nodes or links to make the network more compact and
therefore faster in generating routes or isochrones. 

Several functions rely on creating small buffers for locating the problems. Therefore we
recommend that you avoid having street sections shorter than the size of these buffers or
the result of the analysis gets distorted. This is especially true for the Close Nodes  and
the Node-Link check  functions.

7.1 Add Node Layer

Go to Analyze > Add Node Layer 

When you use this function you will get a new table added to your map window. The layer
shows the nodes that are used as a part of the network. It may assist you while you are
working with the network functions.

The node layer has these attributes: The internal ID (1, 2, 3 .....) and the degree. Degree is
a number >=1 and denotes the number of links attached to the node.

You will normally find that most nodes has a degree of 1, 2, 3 and 4, but larger values are
also possible.

The default colours should help in locating topological issues:

(1) Big red dot - Dangling node / end of cul-de-sac (look for these in odd places)
(2) Little back dot - Cosmetic node joins two roads but could be joined together if required
(3) Medium Blue dot - T-junction
(4) medium magenta dot - 4 or more way intersection.

An example of this is shown below:
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7.2 Close Nodes

Go to Analyze > Close Nodes 

In almost any digitized network you may be able to find 2 or more polylines, which should
have snapped but doesn't . This causes breaks in the network and therefore routes not
generated correctly. The function for detecting such problems is a very powerful tool for
anyone working with street data, where the quality may not have been thoroughly checked.
It is important that you only use this function without the z-levels being when
creating the network .

When this option is selected the following dialog is displayed:

Simply enter the maximum distance between nodes that you wish to identify. You should
only use rather small values (such as 0.005 km = 5 meters) or a very large table will be
generated. Only pairs of nodes, that are not connected by a link, will be identified.
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In this instance the results are two nodes that are close together and not actually
connected. The gap is connected by a line.

This browser is displayed after the function has completed to help in detecting the close
nodes. You can select a record from this browser and then use right click in the map
window and then select "Find Selection" to move to that point on the map.

7.3 Node-Link Check

Go to Analyze > Node-Link Check 

This function will check the number of links in a buffer around each node and check if the
links are connected to the node. Where this does not match the node-link combination is
reported. It is important that you only use this function without the z-levels being
when creating the network .

On selecting this option the following dialog is displayed:
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This function can take a long time to run on large networks but you can monitor the
progress

When the function is complete the following dialog will be displayed:

A browser is then displayed 

You will now have to examine these point and split the link at the node if necessary or
perform other editing that is needed to correct the problem.

Here is a map, that shows the type of error that might be found:
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In the above example the distance from a link to a node is less than the distance specified

You can see here that there is a link that does not break at a node junction.

You can select a record from the browser and then use right click in the map window and
then select "Find Selection" to move to that point on the map.

7.4 Overpasses Check

Go to Analyze > Overpasses Check 

This is used to check for links that do not break at intersections or what could also be just a
bridge. This may cause problems when generating routes or be deliberately. It is
important that you only use this function without the z-levels being when creating
the network .

At the end of the function the map will display the locations:
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The points on the map mark the "Over Passes".

A browser is displayed with the link number and the position of the overpass along the link
in terms of a percentage where 1 = 100% You can select a record from this browser and
then use right click in the map window and then select "Find Selection" to move to that point
on the map.

7.5 Select Cul-De-Sac

Go to Analyze > Select Cul-de-Sacs 

Identifies cul-de-sac or blind alleys, which are defined like this:

Position yourself in a node and drive in one direction using link A. If you can't get back to
the same node without using the same link A again, it is a cul-de-sac. 

If you however can come back without making a U-turn, it is a bridge  in graph theory
terms: If the link was missing, the network would be split into 2 components or subnets. 

A map is shown below:
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This browser is displayed after the function has completed to help in detecting the Cul-De-
Sacs. 

You can select a record from this browser and then use right click in the map window and
then select "Find Selection" to move to that point on the map.

Please note that settings such as one-ways, avoiding no through roads, limits and avoids
may affect the results. Therefore we recommend that this test is run without any of those
setting being active.

7.6 Select Subnets

Go to Analyze > Select Subnets 

Detects which part of a network is a subnet. A subnet is defined as a part of the network
that isn't connected to the rest of the network. The main net is defined as the part of the
network, where node 1 is found. Node 1 is the one with the highest degree and if there are
more than one of these, it is the West-most.

The following dialog is displayed:
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If you click "Yes" then you may be prompted to add a result column to your table:

This will update the network table with the records that are in a subnet.

After Pressing "OK" the Browser is displayed. This are all the links found in a subnet:

Below is a map that shows a subnet identified by the function.
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Please note that settings such as one-ways, avoiding no through roads, limits and avoids
may affect the results. Therefore we recommend that this test is run without any of those
setting being active.

(The OSM Sample data has no subnets)

7.7 Select Subnets (Extended)

Go to Analyze > Select Subnets (Extended) 

Detects which part of a network is a subnet as defined by the attributes of the network.
Such as an area you enter via a one way street but then there is no way out of that area.

After Pressing "OK" the Browser is displayed. This are all the links found in an extended
subnet.

Below is a map that shows a subnet identified by the function
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.

(The OSM Sample data has no extended subnets)

Please note that settings such as one-ways, avoiding no through roads, limits and avoids
may affect the results. Therefore we recommend that this test is run without any of those
setting being active.

7.8 Select Bridges

Go to Analyze > Select Bridges 

This function will detect areas of the network where removing a link would result in subnets.
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An example on where this might be useful would be to identify links that might be vulnerable
to disruption (eg. flooding) and then if that would isolate other areas of the network.
Therefore difficult to reach any people in that area.

Please note that settings such as one-ways, avoiding no through roads, limits and avoids
may affect the results. Therefore we recommend that this test is run without any of those
setting being active.


